BigBlueButton Kurulumu Sonrası Geçersiz BigBlueButton bitiş noktası hatası

Merhaba Arkadaşlar;
8 cpu 16 gb Ram Nat arkasında VM makinaya buradaki adımlara göre yeni kurulum yaptım.

Kurulum sonrası login olduktan sonra tüm kayıtlar,sunucu odaları gibi yerlere erişmeye çalıştığım zaman;
Sunucu hatası , Geçersiz BigBlueButton bitiş noktası ve gizli
Lütfen doğru adımların yürütüldüğünden emin olun Daha fazla
şeklinde sayfanın ortasında hata mesajı görünüyor.
Kendi wildcard sertifikamı kullandım. Bu hata devam etti. Sonra kurulum adımlarındaki encrypt ile denedim yine olmadı, sonra tekrar wildcartımı yükledim ve buradaki adımları uyguladım.
Değişen bir şey yok.
Bu konu hakkında fikir sahibi arkadaşların yardımını beklerim.
Saygılarımla…

Selamlar,

Şurada hata yapmış olabilirsiniz yeniden kontrol eder misiniz?

bahsettiğiniz yerle ilgili sorun görünmüyordu. Biraz daha kontrol ettim, baktım olmuyor uçurdum yeniden kurdum :slight_smile:

Şimdi Başka bir sorun var.
Katıl butonuna basıp oturum başlatıyorum. Ses ile katıl butonuna basıyorum. Aşağıdaki resimdeki gibi ses testine bağlanılıyor yazıyor ekranda…
image
Biraz bekledikten sonra dol üst köşede;

image
Websoket bağlantısı kurulamıyor (hata 1002) mesajını alıyoum.

nano /etc/kurento/modules/kurento/WebRtcEndpoint.conf.ini

dosyasını açtım;
;externalAddress=10.20.30.40
kısmına dış ip adresini yazdım, yeniden başlattım olmadı.

Hocam elle kurulumda bende bu hatayla karşılaşmıştım ve güvenlik duvarında 16384 ile 32768 bağlantı noktaları aralığına izin verince çözmüştüm bir deneyin, olmadı farklı ilerleyelim.

Merhaba,
Hocam zaten güvenlik duvarında izinliydi. Tekrar kontrol ettim, hatta full forward yaptık denemek için ancak buradan kaynaklanan bir durum değil.

Merhaba,
Hocam Ben bu sorunu aşamadım.
Firewall ve NAT ile ilgili bir sorun görünmüyor;

curl --trace-ascii - -k https://EXTERNAL-IP-ADDRESS:443/bigbluebutton/api

testi denediğim zaman;

0004: <response>
0010: <returncode>SUCCESS</returncode>
0032: <version>2.0</version>
004a: </response>
0057: 0
005a:
<response>
<returncode>SUCCESS</returncode>
<version>2.0</version>
</response>== Info: Connection #0 to host DIŞ_IP_ADRESİM left intact

BBB yi restart edince;

# Potential problems described below
....................
# Warning: The setting of (Dış ip adresim) for proxy_pass in
#
#    /etc/bigbluebutton/nginx/sip.nginx
#
# does not match the local IP address ((local ip adresim)).
# (This is OK if you've manually changed the values)

firewall arkasında nat ile yapılandırılmış kurento ve freeswitch file örneği varsa paylaşabilir misin?
Bu iki konfig ile alakalı bir sorun olduğunu düşünüyorum.
Teşekkür ederim.

Selam, saçma gelecek ama şu komutu düzenleyip, çalıştırıp, BBB yeniden başlatır mısın?

sudo bbb-conf --setip sunucuipadresiniz

Merhaba,
Bu işlemi denedim.
sistem linkini tarayıcıya yapıştırıp giriş yapmayı denedim.
image hatası ile birlikte.
Sayfanın ortasında;

image
Link yönlendirmesi yapmadı. bigbloubutton.alanadim.com adresini yazınca bibloubutton.alanadim.com/b adresine yönlendirmesi gerekiyordu.
Başına https:// koyunca yönlendirme yaptı. image düzeldi.
Yayın başlatmak için mavi butona basınca ;
2020-05-07 14_07_34-Window
Riski kabul ederek devam et, dedim.

image
Tekrar giriş yap deyince yukardaki işlemlerin aynısı kısır döngü halinde.

NAT arkasındasın sen değil mi? Hangi IP yazdın iç mi dış mı? Birde hızlı kurulum yapmayı dener misin?

Şuradan:

Bende NAT arkasında kullandığım BBB örneği yok.
@Ferdi_kilic hocam siz silmediyseniz ilgili dosya içeriklerini paylaşma şansınız var mı?

Evet NAT arkasındayım. Dış ve iç ip adreslerinin ikisini de denedim.

 sudo bbb-conf --check

Hocam bu komutu çalıştırıp çıktısını yapıştırırmısınız?

Hocam test ortamı olduğu için sildim. Tekrar kurup arkadaşlar ile paylaşalım. Bazen kurulum esnasında eksiklikler olabiliyor. İkinci kurulum çözüm oluyor.

Hocam bbb sunucunuza bir interface daha ekleyin ip adresi olarak da global ip adresinizi girin 78.165.79.25/32 gibi.
Bu komut il

sudo ip addr add EXTERNAL\_IP\_ADDRESS/32 dev lo

Bu komutu kullanarak kontrol edin

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet EXTERNAL_IP_ADDRESS/32 scope global lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever

Ardından bunu düzenleyin
/opt/freeswitch/conf/sip_profiles/external.xml

<param name="wss-binding"  value="EXTERNAL_IP_ADDRESS:7443"/>

Böyle olduğundan emin olun.
Son olarak
/etc/network/interfaces buraya girin

auto lo
iface lo inet loopback
        post-up ip addr add EXTERNAL_IP_ADDRESS/32 dev lo
        pre-down ip addr del EXTERNAL_IP_ADDRESS/32 dev lo

loopback interface ayarlarınızı bu şekilde düzenleyin

2 Beğeni

Hocam,
Bende bu /opt/freeswitch/conf/sip_profiles/external.xml dosyası içi boş.
bu durum normal mi?
external external-ipv6 external-ipv6.xml external.xml internal-ipv6.xml internal.xml
dosyaları var ayrıca dizinde.

Kurulum eksik hocam freeswitchi yediden kurun yada temiz kurulum yapın

Sizde boş olan dosyanın içeriği bende aşağıdaki gibi.

IPADRESI kısmını kendine göre düzenlemelisin.
Şu kısımda benim dış IP adresim yazmakta:

<param name="wss-binding"  value="IPADRESI:7443"/>

Dosyanın orijinal içeriği:

<profile name="external">

  <!-- http://wiki.freeswitch.org/wiki/Sofia_Configuration_Files -->

  <!-- This profile is only for outbound registrations to providers -->

  <gateways>

    <X-PRE-PROCESS cmd="include" data="external/*.xml"/>

  </gateways>

  <aliases>

    <!--

        <alias name="outbound"/>

        <alias name="nat"/>

    -->

  </aliases>

  <domains>

    <domain name="all" alias="false" parse="true"/>

  </domains>

  <settings>

    <param name="debug" value="0"/>

    <!-- If you want FreeSWITCH to shutdown if this profile fails to load, uncomment the next line. -->

    <!-- <param name="shutdown-on-fail" value="true"/> -->

    <param name="sip-trace" value="no"/>

    <param name="sip-capture" value="no"/>

    <param name="rfc2833-pt" value="101"/>

    <!-- RFC 5626 : Send reg-id and sip.instance -->

    <!--<param name="enable-rfc-5626" value="true"/> -->

    <param name="sip-port" value="$${external_sip_port}"/>

    <param name="dialplan" value="XML"/>

    <param name="context" value="public"/>

    <param name="dtmf-duration" value="2000"/>

    <param name="inbound-codec-prefs" value="$${global_codec_prefs}"/>

    <param name="outbound-codec-prefs" value="$${outbound_codec_prefs}"/>

    <param name="hold-music" value="$${hold_music}"/>

    <param name="rtp-timer-name" value="soft"/>

    <!--<param name="enable-100rel" value="true"/>-->

    <!--<param name="disable-srv503" value="true"/>-->

    <!-- This could be set to "passive" -->

    <param name="local-network-acl" value="localnet.auto"/>

    <param name="manage-presence" value="false"/>

    <!-- Added for Microsoft Edge browser -->

    <param name="apply-candidate-acl" value="localnet.auto"/>

    <param name="apply-candidate-acl" value="wan_v4.auto"/>

    <param name="apply-candidate-acl" value="rfc1918.auto"/>

    <param name="apply-candidate-acl" value="any_v4.auto"/>

    <!-- used to share presence info across sofia profiles

         manage-presence needs to be set to passive on this profile

         if you want it to behave as if it were the internal profile

         for presence.

    -->

    <!-- Name of the db to use for this profile -->

    <!--<param name="dbname" value="share_presence"/>-->

    <!--<param name="presence-hosts" value="$${domain}"/>-->

    <!--<param name="force-register-domain" value="$${domain}"/>-->

    <!--all inbound reg will stored in the db using this domain -->

    <!--<param name="force-register-db-domain" value="$${domain}"/>-->

    <!-- ************************************************* -->

    <!--<param name="aggressive-nat-detection" value="true"/>-->

    <param name="inbound-codec-negotiation" value="generous"/>

    <param name="nonce-ttl" value="60"/>

    <param name="auth-calls" value="false"/>

    <param name="inbound-late-negotiation" value="true"/>

    <param name="inbound-zrtp-passthru" value="true"/> <!-- (also enables late negotiation) -->

    <!--

        DO NOT USE HOSTNAMES, ONLY IP ADDRESSES IN THESE SETTINGS!

    <param name="rtp-ip" value="$${local_ip_v4}"/>

    <param name="sip-ip" value="$${local_ip_v4}"/>

    <param name="ext-rtp-ip" value="auto-nat"/>

    <param name="ext-sip-ip" value="auto-nat"/>

    -->

    <param name="rtp-ip" value="$${local_ip_v4}"/>

    <param name="sip-ip" value="$${local_ip_v4}"/>

    <param name="ext-rtp-ip" value="$${local_ip_v4}"/>

    <param name="ext-sip-ip" value="$${local_ip_v4}"/>

    <param name="rtp-timeout-sec" value="300"/>

    <param name="rtp-hold-timeout-sec" value="1800"/>

    <param name="enable-3pcc" value="proxy"/>

    <!-- TLS: disabled by default, set to "true" to enable -->

    <param name="tls" value="$${external_ssl_enable}"/>

    <!-- Set to true to not bind on the normal sip-port but only on the TLS port -->

    <param name="tls-only" value="false"/>

    <!-- additional bind parameters for TLS -->

    <param name="tls-bind-params" value="transport=tls"/>

    <!-- Port to listen on for TLS requests. (5081 will be used if unspecified) -->

    <param name="tls-sip-port" value="$${external_tls_port}"/>

    <!-- Location of the agent.pem and cafile.pem ssl certificates (needed for TLS server) -->

    <!--<param name="tls-cert-dir" value=""/>-->

    <!-- Optionally set the passphrase password used by openSSL to encrypt/decrypt TLS private key files -->

    <param name="tls-passphrase" value=""/>

    <!-- Verify the date on TLS certificates -->

    <param name="tls-verify-date" value="true"/>

    <!-- TLS verify policy, when registering/inviting gateways with other servers (outbound) or handling inbound registration/invite requests how should we verify their certificate -->

    <!-- set to 'in' to only verify incoming connections, 'out' to only verify outgoing connections, 'all' to verify all connections, also 'in_subjects', 'out_subjects' and 'all_subjects' for subject validation. Multiple policies can be split with a '|' pipe -->

    <param name="tls-verify-policy" value="none"/>

    <!-- Certificate max verify depth to use for validating peer TLS certificates when the verify policy is not none -->

    <param name="tls-verify-depth" value="2"/>

    <!-- If the tls-verify-policy is set to subjects_all or subjects_in this sets which subjects are allowed, multiple subjects can be split with a '|' pipe -->

    <param name="tls-verify-in-subjects" value=""/>

    <!-- TLS version ("sslv23" (default), "tlsv1"). NOTE: Phones may not work with TLSv1 -->

    <param name="tls-version" value="$${sip_tls_version}"/>

    <param name="ws-binding"  value=":5066"/>

    <param name="wss-binding"  value="IPADRESI:7443"/>

    <!-- enable rtcp on every channel also can be done per leg basis with rtcp_audio_interval_msec variable set to passthru to pass it across a call-->

    <param name="rtcp-audio-interval-msec" value="5000"/>

    <param name="rtcp-video-interval-msec" value="5000"/>

    <!-- Cut down in the join time -->

    <param name="dtmf-type" value="info"/>

    <param name="liberal-dtmf" value="true"/>

  </settings>

</profile>
1 Beğeni

Hocam az önce nasıl bir hata yaptıysam boş değilmiş içi. Affedersiniz.
Dosyayı açtım ip adresi kısmı boşdu. ip adresini girdim. interfaceleri de girdim.
Son durum yukarıdaki durum devam ediyor.
En iyisi şöyle olacak, ilk kurulum bittiğinde backup almıştım. backupa geri dönüp dediklerinizi tekrar yapayım.

Hocam tek tıkla kurulumu denediniz mi peki?

Denemedim Hocam, kapsamlı manuel kurulumu uygulamıştım.

Belki bir adımı atlamış olabiliriz diye düşündüm, olabiliyor ben anlatımı bile 2 defa deneyerek ekleme çıkarma yaparak tamamladım :slight_smile: