BigBlueButton Mikrofon Sorunu

Merhabalar,

Bugün bir toplantı sırasında sorun çıktı. Neyden kaynaklandığını bilmiyorum.
Toplantıya Telefondan katılan kişiler her şey sorunsuz çalışıyor.
Ben kendi bilgisayarımdan iç network den bağlanıyorum. Mac kullanıyorum. Mikrofon kamera sorunsuz çalışıyor. Windows yüklü makinelerde mikrofon simgesine tıkladığı anda ‘’ ice error 1007’’ hatası alıyorum.

[email protected]:~# sudo bbb-conf --check

BigBlueButton Server 2.2.19 (2025)
Kernel version: 4.4.0-186-generic
Distribution: Ubuntu 16.04.6 LTS (64-bit)
Memory: 16432 MB
CPU cores: 4

/usr/share/bbb-web/WEB-INF/classes/bigbluebutton.properties (bbb-web)
bigbluebutton.web.serverURL: 1
defaultGuestPolicy: ALWAYS_ACCEPT
svgImagesRequired: true

/etc/nginx/sites-available/bigbluebutton (nginx)
server name: 1
port: 80, [::]:80
port: 443 ssl
bbb-client dir: /var/www/bigbluebutton

/var/www/bigbluebutton/client/conf/config.xml (bbb-client)
Port test (tunnel): rtmp://1
red5: 1
useWebrtcIfAvailable: true

/opt/freeswitch/etc/freeswitch/vars.xml (FreeSWITCH)
local_ip_v4: 1
external_rtp_ip: stun:stun.freeswitch.org
external_sip_ip: stun:stun.freeswitch.org

/opt/freeswitch/etc/freeswitch/sip_profiles/external.xml (FreeSWITCH)
ext-rtp-ip: $${local_ip_v4}
ext-sip-ip: $${local_ip_v4}
ws-binding: :5066
wss-binding: 1:7443

/usr/local/bigbluebutton/core/scripts/bigbluebutton.yml (record and playback)
playback_host: 1
playback_protocol: https
ffmpeg: 4.2.2-1bbb1~ubuntu16.04

/etc/bigbluebutton/nginx/sip.nginx (sip.nginx)
proxy_pass: 1

/usr/local/bigbluebutton/bbb-webrtc-sfu/config/default.yml (Kurento SFU)
kurento.ip: 1
kurento.url: ws://127.0.0.1:8888/kurento
kurento.sip_ip: 1
localIpAddress: 1
recordScreenSharing: true
recordWebcams: true
codec_video_main: VP8
codec_video_content: VP8

/usr/share/meteor/bundle/programs/server/assets/app/config/settings.yml (HTML5 client)
build: 960
kurentoUrl: wss://1/bbb-webrtc-sfu
enableListenOnly: true

Potential problems described below

[email protected]:~#

[email protected]:~# sudo bbb-conf --status
nginx —————————————————► [:heavy_check_mark: - active]
freeswitch ————————————► [:heavy_check_mark: - active]
redis-server ——————————► [:heavy_check_mark: - active]
bbb-apps-akka —————————► [:heavy_check_mark: - active]
bbb-transcode-akka ————► [:heavy_check_mark: - active]
bbb-fsesl-akka ————————► [:heavy_check_mark: - active]
red5 ——————————————————► [:heavy_check_mark: - active]
mongod ————————————————► [:heavy_check_mark: - active]
bbb-html5 —————————————► [:heavy_check_mark: - active]
bbb-webrtc-sfu ————————► [:heavy_check_mark: - active]
kurento-media-server ——► [:heavy_check_mark: - active]
etherpad ——————————————► [:heavy_check_mark: - active]
bbb-web ———————————————► [:heavy_check_mark: - active]
[email protected]:~#

[email protected]:~# ufw status
Status: inactive

Ne yaptıysam beceremedim. Sitede bu sorunu alan arkadaşların çözümlerini denedim beceremedim forumlara baktım yine sorunu çözemedim. Yardımcı olabilecek birisi var mı lütfen.

sorun tamamen iç hattan baglanmandan dolayı eger bilgisayarı kendi ceptelefonu hattından mobil hattan baglarsan sorun olmadıgını görürsün…
NAT bacağında 80 portu yönlendirmesi sırasında bir hata meydana geliyor ondan dolayıda benimde çözemediğim bir olay bu 80 portu iç hattan gelince saçmalıyor ve hataya düşüyor. dene bak anlayacaksın lan degılde WAN üzerinden gelirsen… sanırım orda yazılım LANdan gelmen için bir protokolü eksik. sonuçta bu yazılım web üzerinden oldugundan online LAN sistemine karşı bir aksiyon alınmamış.

Sorun bizim Labris Güvenlik cihazından kaynaklandığı tespit ettik şans eseri. Sosyal Medya izinli bir kural var o kısma ekleyince sorun çözüldü. Open Source yazılımlar’ da sorun yok gibi aslında. Aptalca yapılandırılmış düzgün çalışmayan güvenlik duvarında sorun var.

2 Beğeni