Zimbra Dahili E-postaların Spam Olarak İşaretlenmesini Önleyin

Sorun:

Zimbra e-posta sisteminde başka bir dahili hesaba dahili bir e-posta gönderildiğinde, spam olarak işaretleniyor.

Çözüm:

Zimbra sunucunuza SSH ile bağlantı sağlayın ve aşağıdaki komutları sırası ile yazın;

su - zimbra
zmprov ms 'zmhostname' zimbraAmavisOriginatingBypassSA TRUE
zmamavisdctl restart  

Daha sonra ise aşağıdaki komutu girin ve ilgili dosyamızı düzenlemek için açın;

nano /opt/zimbra/conf/amavisd.conf.in

Şu kısmı bulun;

$policy_bank{'ORIGINATING'} = {  # mail supposedly originating from our users
  originating => 1,  # declare that mail was submitted by our smtp client
  allow_disclaimers => %%binary VAR:zimbraDomainMandatoryMailSignatureEnabled%%,  # enables disclaimer insertion if available
  # notify administrator of locally originating malware
  virus_admin_maps => ['@@[email protected]@'],
  spam_admin_maps  => ['@@[email protected]@'],
  warnbadhsender   => 0,

Hemen altına şunları ekleyin;

  bypass_spam_checks_maps   => [1], # dahili e-postalarda spam kontrolunu pasiflestir
  bypass_virus_checks_maps   => [1], # dahili e-postalarda virus kontrolunu pasiflestir

Dosyayı kaydedip kapatın ve Amavisd hizmetini aşağıdaki komut ile yeniden başlatın;

zmamavisdctl restart

Şimdi tekrar dahili e-posta sisteminizde gerekli gönderim testlerini yapabilirsiniz.

Merhaba; Bu anlatılanlar ne yazık ki benim için işe yaramadı. Hala lokal mail adreslerinden gelen mailler istenmeyen klasörüne düşüyor. Başka ne gibi sorun olabilir?

zmprov ms 'zmhostname' zimbraAmavisOriginatingBypassSA TRUE

Merhaba, bu komutu Zimbra kullanıcısı olarak çalıştırdınız değil mi?

Evet çalıştırdım. ‘zmhostname’ yenine kendi hostname adımı yazıyorum dimi?

Hayır, direkt komutu çalıştırıp deneyin lütfen.

bu komutu direk çalıştırınca;
ERROR: account.NO_SUCH_SERVER (no such server: zmhostname)
hatası veriyor. ‘zmhostname’ yerine mail.xxxx.xom.tr hostname adını yazınca hiç bir dönüş olmadan tamamlıyor. Bir gariplik var ama bilemedim. hala lokal mailler spam a düşüyor. Üstelik Spam değil olarak işaretle desem bile fark etmiyor hep spam. çözemedim. Teşekkürler ilginize.

Sanırım benim sistemimde sorun var. Bloğunuzdan Taşıma Rehberi ile sistemi taşıyorum. Sorunsuz sıfır bir sistemde denicem. Teşekkürler tüm destekleriniz için.

1 Beğeni

Taşıma rehberindeki adımlarla sorunsuz taşımayı başardım. Şuan hiçbir problem yok. Teşekkürler ilginize. İyi çalışmalar.

1 Beğeni